Sicherheitslücke bei WordPress-Plugin: Advanced Access Manager (AAM)

advanced access manager BYPASS
Aktuell wurde uns eine Sicherheitslücke bei dem WordPress Plugin Advanced Access Manager by Vasyl Martyniuk gemeldet. Was zu tun ist, ein paar Details zur Sicherheitslücke und allgemeine Infos zum Plugin findet ihr regelmäßig in unserem Blog — für beliebte Plugins ab 100.000+ aktiven Nutzern.

 

Das WordPress Plugin: Advanced Access Manager (AAM)

Advanced Access Manager ist ein beliebtes Plugin, mit dem man bereits in der Free-Version viele Freiheiten zur Erstellung und Verwaltung von Benutzerkonten und Benutzerrollen hat. Es ermöglicht die einfache Steuerung der Zugriffsberechtigung zu einzelnen Seiten oder Beiträgen nach Nutzerrollen oder Besuchern. Dabei ist das Plugin benutzerfreundlich und kommt ohne Werbung aus. AAM zählt laut WordPress.org aktuell über 100.000 aktive Nutzer.

 

Sicherheitslücke: Bypass

Das Plugin Advanced Access Manager (bis zu Versionen < 5.9.9) ermöglicht das Lesen beliebiger Dateien ohne zuvor zuverlässig zu prüfen, ob ein entsprechender Nutzer dazu berechtigt ist. Auf diesem Weg kann die wp-config.php heruntergeladen werden, wodurch im Allgemeinen auch Zugriff auf die Datenbank gegeben ist.

Die Sicherheitslücke kann geschlossen werden, indem das Plug-In auf die neueste Version (5.9.9) aktualisiert wird.

Quelle: https://wpvulndb.com/vulnerabilities/9873
Bekannt geworden am 09.09.2019

 

 

Falls du über den HostPress SecurePlan verfügst, haben wir für dich bereits das neueste Sicherheitsupdate durchgeführt.